`
EmmaZhao
  • 浏览: 32110 次
  • 性别: Icon_minigender_2
  • 来自: 北京
最近访客 更多访客>>
社区版块
存档分类
最新评论

ZOJ1004 Anagrams by Stack

    博客分类:
  • zoj
 
阅读更多
Time Limit: 1 Second      Memory Limit: 32768 KB

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]
where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]
and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.
Process

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)
Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice
Sample Output

[
i i i i o o o i o o
i i i i o o o o i o
i i o i o i o i o o
i i o i o i o o i o
]
[
i o i i i o o i i o o o
i o i i i o o o i o i o
i o i o i o i i i o o o
i o i o i o i o i o i o
]
[
]
[
i i o i o i o o
]
Source: Zhejiang University Local Contest 2001


import java.util.Scanner;
import java.util.Stack;


public class Main {
	private Stack<Character> io;
	private Stack<Character> op;
	private int l;
	private String str1,str2;
	
	public Main(String str1,String str2){
		io = new Stack<Character>();
		op = new Stack<Character>();
		this.str1 = str1;
		this.str2 = str2;
		l = str1.length();
	}
	
	public static void main(String[] args){
		Scanner scanner = new Scanner(System.in);
		String str1,str2;
		while(scanner.hasNext()){
			str1 = scanner.nextLine();
			str2 = scanner.nextLine();
			Main m = new Main(str1, str2);
			
			System.out.println("[");
			m.dfs(0, 0);
			System.out.println("]");
		}
	}
	
	public void print(){
		for(int i = 0;i< io.size();i++){
			System.out.print(io.elementAt(i) + " ");
		}
		System.out.println();
	}
	
	public void dfs(int in,int out){
		if((in == l) && (out == l)){
			print();
		}
		if(in < l){
			op.push(str1.charAt(in));
			io.push('i');
			dfs(in+1,out);
			op.pop();
			io.pop();
		}
		if((out < l) && (out < in) && (op.lastElement().equals(str2.charAt(out)))){
			char t = str2.charAt(out);
			op.pop();
			io.push('o');
			dfs(in,out+1);
			op.push(t);
			io.pop();
		}
		
	}
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics